اسكربتات تم تجربتها واثبتت نجاحها بنسبة كبيرة

استعرض الموضوع السابق استعرض الموضوع التالي اذهب الى الأسفل

اسكربتات تم تجربتها واثبتت نجاحها بنسبة كبيرة

مُساهمة من طرف فهد محمد في الثلاثاء نوفمبر 29, 2016 9:31 pm

هل من الممكن ان يقوم كل عضو بنشر اي اسكربت قام بتجربتة شخصيا واثبت انه يعمل بشكل سليم Smile
كمثال هذا اسكربت دمج خطين بطريقة PCC واثبتت نجاحها بدرجة كبيرة جدا ولها اكثرمن سنة ونصف تعمل بشكل مستقر جدا
الكود:
اولاً نقوم بتسمية كرت الدخول الخاص بالخط الاول بالاسم (WAN1)
ثانيا نقوم بتسمية كرت الدخول الخاص بالخط الثاني بالاسم (WAN2)
ثالثا نقوم بتسمية كرت الخروج بالاسم (Local)



/ip address
add address=192.168.0.1/24 interface=Local network=192.168.0.0
add address=192.168.1.2/24 interface=WAN1 network=192.168.1.0
add address=192.168.2.2/24 interface=WAN2 network=192.168.2.0


/ip dns
set allow-remote-requests=yes cache-size=5000KiB max-udp-packet-size=512 \
    servers=82.114.160.39,82.114.160.38,8.8.8.8,8.8.4.4

/ip firewall mangle
add action=mark-connection chain=input in-interface=WAN1 new-connection-mark=\
    WAN1_conn
add action=mark-connection chain=input in-interface=WAN2 new-connection-mark=\
    WAN2_conn

add action=mark-routing chain=output connection-mark=WAN1_conn \
    new-routing-mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN2_conn \
    new-routing-mark=to_WAN2

add chain=prerouting dst-address=192.168.1.0/24 in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 in-interface=Local

add action=mark-connection chain=prerouting dst-address-type=!local \
    in-interface=Local new-connection-mark=WAN1_conn per-connection-classifier=\
    both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local \
    in-interface=Local new-connection-mark=WAN2_conn per-connection-classifier=\
    both-addresses-and-ports:2/1

add action=mark-routing chain=prerouting connection-mark=WAN1_conn \
    in-interface=Local new-routing-mark=to_WAN1
add action=mark-routing chain=prerouting connection-mark=WAN2_conn \
    in-interface=Local new-routing-mark=to_WAN2

/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1
add action=masquerade chain=srcnat out-interface=WAN2

/ip route
add check-gateway=ping distance=1 gateway=192.168.1.1 routing-mark=to_WAN1
add check-gateway=ping distance=1 gateway=192.168.2.1 routing-mark=to_WAN2
add check-gateway=ping distance=1 gateway=192.168.1.1
add check-gateway=ping distance=2 gateway=192.168.2.1


/system clock
set time-zone-name=Asia/Aden

/system ntp client
set enabled=yes primary-ntp=123.108.225.6 secondary-ntp=129.250.35.250

/system identity
set name=Fahd_Net_LB(733830251)

فهد محمد

المساهمات : 1
تاريخ التسجيل : 29/11/2016

معاينة صفحة البيانات الشخصي للعضو

الرجوع الى أعلى الصفحة اذهب الى الأسفل

استعرض الموضوع السابق استعرض الموضوع التالي الرجوع الى أعلى الصفحة


 
صلاحيات هذا المنتدى:
لاتستطيع الرد على المواضيع في هذا المنتدى